Weird views and major portal troubles!

Any aspects of level design for the Source engine.

Weird views and major portal troubles!

Postby Megadude on Thu Jan 31, 2008 1:03 am

A few questions.

1. At the beginning of my map, when I'm looking through the glass. I sometimes get differences in what shade the walls in my map are, when looking through the glass.

Image

Image

Image

As you can see in the pics, for some reason you can see some lines where there are not supposed to be any, and on either side of the lines the shading is different. Cubemaps have been built and map has been restarted. Could this be caused by the player being in what is basically a glass room, or is something else causing this?


2. In my map, I've got those self-creating portals that you see near the beginning of Portal. I've got several of them in one room, and they keep turning on and off, (they are all orange btw). However, if the player shots their blue portal at a surface where an orange portal is going to be, and they both activate at the same time, the orange portal is cancelled out, and it then appears wherever the player next shoots their blue portal, therefore moving the orange portal for the rest of the game, ( stay with it, I'm getting to the conclusion soon).

Deactivating then reactivating the portals doesn't reset the portals to their original positions, and placing func_noportal_volumes to block the incoming blue portals doesn't work, unless they are right next to the wall, but that stops the orange portals. Is this an unavoidable bug, or can this situation be stopped?


That is the end of my essay :lol:


Edit: Ignore the upper parts of the 1st and 3rd pic. That's another pic that was there before I pasted the correct one on top of it.


Edit 2: Problem 3 - now fixed. Have now developed a MAJOR problem. In the same room as the one mentioned above, I want the non-player made protals to be all orange. However when testing the map, I've found that the portals are orange for the first 3 that open, then they change colour to blue for the next 3, then back to orange. They always change colour after 3 portals have opened. There are only 4 in the room, and only 1 is ever active at once. This problem will completly trash the gameplay unless there is a solution. Any know of one? :cry:

Edit 3: My big problem is solved. That only seems to happen if you close one portal and open the next at the same time. Making a delay of a fraction of a second between the opening/closing solved it :smt118 The first 2 problems still remain though.
Wrathborne 711 wrote:OH MY GOD.........MEXICANS!


Image

End of Humanity - beta version 3.0 released!
User avatar
Megadude
Veteran
Veteran
 
Joined: Tue Sep 20, 2005 6:20 pm
Location: UK

Return to Hammer Editor Help

Who is online

Users browsing this forum: No registered users