Rebel NPC's doesn't speak

Any aspects of level design for the Source engine.

Rebel NPC's doesn't speak

Postby Mark Richard on Fri May 11, 2007 6:23 pm

As stated in the thread name, the rebel NPC's in my mod doesn't say anything when I "Use" them.

As you know, in Half-Life 2/EP1 when you "Use" a rebel NPC, the NPC says something random, like:

I think I ate something bad, I can't belive this day has finaly come, I'm glad there are no kids around to see this, etc, etc..

Unless I don't use a choreographed scene, none of the NPC's are saying anything. To me, this is very irritating.
Yes, I can live with none-speaking-rebels... but if there is someone who knows how to fix this, them I'm eager to hear it!

Btw, I've been told to use the Episode One .dll files. Maybe it has something to do with that. :?
User avatar
Mark Richard
Pheropod
Pheropod
 
Joined: Sat Apr 29, 2006 8:46 pm
Location: The Kingdom of Sweden

Postby Broodrooster on Mon May 14, 2007 1:08 pm

there is a entity called "ai_citizen_response_system"
, i guess yo have to place it in your map (dont know how it works exactly)
Broodrooster
Regular
Regular
 
Joined: Tue Aug 15, 2006 4:40 pm
Location: The Netherlands

Postby marnamai on Sat Jun 30, 2007 9:25 pm

/bump

Me and Hyper Trance are both still having troubles with the npc's responding to the player, as he said before "the rebel NPC's in my mod doesn't say anything when I "Use" them"
In HL2 and EP1 the npc's respond when they are used or when they make room for the player.
Now they don't talk at all and this makes them look like lifeless robots ...

We don't have a clue how to fix this. The response system didn't do the job.

I have decompiled many maps to find out how this was done but there are to my knowledge no special entities involved for the npc's responding.

I think we might be missing some script files? Or does it has to do something with the HL2:EP1 dll's that we 're using?

I suppose we 're not the only modders with this problem. So does anyone has a similar problem or knows a possible sollution?
User avatar
marnamai
Veteran
Veteran
 
Joined: Thu Nov 10, 2005 12:17 pm
Location: Belgium

Postby marnamai on Sat Jun 30, 2007 9:57 pm

I ve been searching on (the now closed) verc forums and I found an old topic by Mr. Greenfish.

Did you found a solution?
User avatar
marnamai
Veteran
Veteran
 
Joined: Thu Nov 10, 2005 12:17 pm
Location: Belgium

Postby Mr. Happy on Sat Jun 30, 2007 10:23 pm

My memory on this is very very dusty, but what you are describing is definitely controlled by the responce contexts.

These are definitely defined by script files, and can be managed on NPC's individualy with their keyvalues, and individually (or in groups) with the ai_speechfilter

There is a script file in scripts/talker/ called response_rules.txt that defines them. I think this is one of those stupid litle all important files that isn't installed when you click the magical "Create a MOD" button. I could be wrong though, I haven't sifted through my own files to check this because I have to run.

All I can suggest is make sure you have this file, and any files it specifies with it's #include lines in your mod folder. If not, well, you know what to do :)
Image
-You've just been happified!?
User avatar
Mr. Happy
Forum Goer Elite™
Forum Goer Elite™
 
Joined: Sat Dec 30, 2006 9:20 am
Location: Flyin' thru "da cloud" in the MotherShip

Postby marnamai on Sat Jun 30, 2007 10:44 pm

Those scripts where in place, I 've added the ep1 scripts to makes sure, but the npc's still won't talk :cry:

EDIT/ when I load my map in EP1 instead of my mod, the npc's do talk! What files am I missing?
User avatar
marnamai
Veteran
Veteran
 
Joined: Thu Nov 10, 2005 12:17 pm
Location: Belgium

Postby Mr. Happy on Sat Jun 30, 2007 10:51 pm

I dunno man :( You didn't accidentally set the gag keyvals/flags on every single npc did you? :(
Image
-You've just been happified!?
User avatar
Mr. Happy
Forum Goer Elite™
Forum Goer Elite™
 
Joined: Sat Dec 30, 2006 9:20 am
Location: Flyin' thru "da cloud" in the MotherShip

Postby marnamai on Sat Jun 30, 2007 11:13 pm

ok, I am creating a new mod now.

from what gcf should I extract to get the latest "working" files. (source sdk base? right?)
User avatar
marnamai
Veteran
Veteran
 
Joined: Thu Nov 10, 2005 12:17 pm
Location: Belgium

Postby Mr. Happy on Sat Jun 30, 2007 11:16 pm

ehh

some of the newest (episode one codebase) stuff is in base source engine 2.gcf, but yeah, thats the original base .gcf

p.s. i posted this issue on the VDC help desk
Image
-You've just been happified!?
User avatar
Mr. Happy
Forum Goer Elite™
Forum Goer Elite™
 
Joined: Sat Dec 30, 2006 9:20 am
Location: Flyin' thru "da cloud" in the MotherShip

Postby marnamai on Sat Jun 30, 2007 11:21 pm

actually there are 2 gfc's

- base source engine 2
- source sdk base

are they both the same build? I think source sdk base it the one from the tool (see tools menu in steam)
User avatar
marnamai
Veteran
Veteran
 
Joined: Thu Nov 10, 2005 12:17 pm
Location: Belgium

Postby Mr. Happy on Sat Jun 30, 2007 11:25 pm

ehh thats what im sayin, but ima pretty sure...


wait a minute, there are three or four different gcf files in my steamapps folder that contain the non client/server dll's.......what t f are the newest ones :smt031


damn you for making me doubt my knowledge of the source!

;)
Image
-You've just been happified!?
User avatar
Mr. Happy
Forum Goer Elite™
Forum Goer Elite™
 
Joined: Sat Dec 30, 2006 9:20 am
Location: Flyin' thru "da cloud" in the MotherShip

Postby marnamai on Sat Jun 30, 2007 11:31 pm

It should be the "source sdk base.gfc" iirc.
User avatar
marnamai
Veteran
Veteran
 
Joined: Thu Nov 10, 2005 12:17 pm
Location: Belgium

Postby mr greenfish on Mon Jul 02, 2007 10:52 am

Hey guys, just so you know this isn't a problem with marnamai's set-up its a bug that came with last years august sdk update

i personally had this problem as marnamai discovered:
http://www.chatbear.com/unity2/4991/343 ... ?v=flatold

the bug is still present almost a year later, however it looks like it's on the verge of being fixed. It is mentioned in the new beta of the SDK:

http://developer.valvesoftware.com/wiki ... ease_Notes
"Added Response Files to Fix the "NPCs Don't Talk" Problem"

No doubt this sdk update will roll out sometime soon
Image Available now
User avatar
mr greenfish
1337 p0st3r
1337 p0st3r
 
Joined: Sat Dec 04, 2004 12:05 pm

Postby marnamai on Mon Jul 02, 2007 11:07 am

bugzilla wrote:Since the August 06 update, npc_citizens no longer talk in new mods.
Whole history on this topic:
http://www.chatbear.com/unity2/4991/343 ... ?v=flatold

------- Additional Comment #1 From Tom Edwards 2007-02-26 04:50 -------
They work fine for me. Try copying
<code>scripts/talker/response_rules.txt</code> from base source engine 2.gcf.

------- Additional Comment #2 From Germano Guerrini 2007-02-26 05:23 -------
Thanks for your help, I've tried, still they don't work. I even tried to mount
content by adding:

filesystem->AddSearchPath("hl2", "GAME");
if ( filesystem->MountSteamContent(215) == FILESYSTEM_MOUNT_FAILED )
return false;

as explained here:
http://developer.valvesoftware.com/wiki ... on_Content

I have been told that Mike Durand is aware of that issue.



------- Additional Comment #3 From Tom Edwards 2007-05-04 05:19 -------
This bug is because the file scripts/talker/response_criteria.txt is missing
from the SDK Base cache. As a workaround, a version can be copied from episode
one shared.gcf.

------- Additional Comment #4 From Mike Durand 2007-05-04 19:38 -------
'response_criteria.txt' and 'response_rules.txt' added to Source SDK Base.


I have both those files in my mod, but the npc's still don't talk!
User avatar
marnamai
Veteran
Veteran
 
Joined: Thu Nov 10, 2005 12:17 pm
Location: Belgium

Postby Mr. Happy on Mon Jul 02, 2007 11:19 am

You know...there's a beta sdk out right now, try it?

hmm...
Image
-You've just been happified!?
User avatar
Mr. Happy
Forum Goer Elite™
Forum Goer Elite™
 
Joined: Sat Dec 30, 2006 9:20 am
Location: Flyin' thru "da cloud" in the MotherShip
Next

Return to Hammer Editor Help

Who is online

Users browsing this forum: Bing [Bot], Google [Bot]