Black Models

Any aspects of level design for the Source engine.

Black Models

Postby andy4729 on Wed Mar 21, 2012 11:04 pm

Sorry for spamming the forums a bit, big deadline approaching and I need to get all my issues sorted! :\

Basically, can anyone help me with this:

Image

Pretty self-explanatory. Certain models are completely black whilst others, right next to them are lit normally!
We're squatting in a system that consistently stalls
User avatar
andy4729
Regular
Regular
 
Joined: Sat Sep 09, 2006 7:26 pm
Location: Canterbury, United Kingdom

Re: Black Models

Postby Will_B on Wed Mar 21, 2012 11:19 pm

The prop_static's origin is probably inside some geometry where light isn't hitting. To work around this try reposition the mesh so it origin is somewhere that light will hit. Or use an 'Info_lighting' entity to specify where to take lighting from. OR check these tutorials out: http://www.tophattwaffle.com/?p=2957

These will show you how to compile per vertex lighting for meshes.
Will_B
Regular
Regular
 
Joined: Mon Oct 31, 2011 12:35 am

Re: Black Models

Postby andy4729 on Wed Mar 21, 2012 11:37 pm

Strangely, this fixed the problem for the rock on the ground but it refuses to fix it for the sign and another rock model which isn't in this screen. I made a new info_lighting for all the different models and everything.

Image
We're squatting in a system that consistently stalls
User avatar
andy4729
Regular
Regular
 
Joined: Sat Sep 09, 2006 7:26 pm
Location: Canterbury, United Kingdom

Re: Black Models

Postby Jangalomph on Thu Mar 22, 2012 3:29 am

Try when compiling maps, compile them in
Code: Select all
-staticproppolies -textureshadows -final
in the command prompt.
http://www.nomoreroominhell.com
I don’t know whether I was right or wrong, I guess I’ll never know… But I made it. And I guess I should be thankful for that. - Strelok
Has anyone really been far even as decided to use even go want to do look more like?
User avatar
Jangalomph
Forum Goer Elite™
Forum Goer Elite™
 
Joined: Wed Jun 25, 2008 3:19 pm
Location: Sumter, SC

Re: Black Models

Postby andy4729 on Thu Mar 22, 2012 12:00 pm

jangalomph wrote:Try when compiling maps, compile them in
Code: Select all
-staticproppolies -textureshadows -final
in the command prompt.


No change.
We're squatting in a system that consistently stalls
User avatar
andy4729
Regular
Regular
 
Joined: Sat Sep 09, 2006 7:26 pm
Location: Canterbury, United Kingdom

Re: Black Models

Postby andy4729 on Thu Mar 22, 2012 12:20 pm

Fixed by scattering some extra light entity around near the black model. Only with like 10 brightness but it was enough.

Pretty weird problem.
We're squatting in a system that consistently stalls
User avatar
andy4729
Regular
Regular
 
Joined: Sat Sep 09, 2006 7:26 pm
Location: Canterbury, United Kingdom

Re: Black Models

Postby Will_B on Fri Mar 23, 2012 12:01 pm

Hey one last thing when using per vertex lighting on models, if the model uses a normal map it will ignore er vertex lighting, and in my experience that has made some of my meshes black, big ones in particular.
Will_B
Regular
Regular
 
Joined: Mon Oct 31, 2011 12:35 am

Re: Black Models

Postby Dives on Fri Mar 23, 2012 6:29 pm

andy4729 wrote:
jangalomph wrote:Try when compiling maps, compile them in
Code: Select all
-staticproppolies -textureshadows -final
in the command prompt.


No change.



I think I should add that Janga spelled one of the commands wrong. Its -staticproppolys.
Contagion Level Designer
User avatar
Dives
Monochrome Games
 
Joined: Sat Feb 28, 2009 9:54 pm
Location: Moorpark, CA

Re: Black Models

Postby andy4729 on Fri Mar 23, 2012 7:05 pm

It's alright Dives. I already had a custom compile setup which has those commands :) I didn't copy them from here.

Will, I think you might be on to something there as all the models that this happens for are one with normal maps!
We're squatting in a system that consistently stalls
User avatar
andy4729
Regular
Regular
 
Joined: Sat Sep 09, 2006 7:26 pm
Location: Canterbury, United Kingdom

Return to Hammer Editor Help

Who is online

Users browsing this forum: No registered users