Upgrade your browser

What's wrong with my browser?

If you've reached this page it's more than likely that you're using an older, more inferior browser such as Internet Explorer 6 or lower

It's a very old browser now (released in 2001) and just can't cut the mustard with today's web standards and other more competent web browsers. We've recently re-written all of the code for Interlopers and seeing as users like yourself make up a very small percent (2.5!) of the userbase we have completely dropped support.

This has allowed us to make the site smarter, faster and easier to maintain as well as thinking towards the future.

So what do I do?

You can upgrade in minutes to one of several superb browsers, they all import details from Internet Explorer so you won't lose a thing and after a little bit of settling in you'll never look back.