Custom texture shows up white in-game

Got problems with your models? Struggling with textures? Get help with your custom assets.

Custom texture shows up white in-game

Postby theCommie on Sun May 03, 2009 1:52 am

The subject line says it all; I have a custom material refusing to compile properly, instead showing up pure white.

The VMT:

Code: Select all
LightmappedGeneric
{
   $basetexture      "mytextures\planks_new002_DIFF"
   $bumpmap      "mytextures\planks_new002_BUMP"
   $envmap         "env_cubemap"
   $basealphaenvmapmask   "1"
   $surfaceprop       "wood"
}


The console writes one line in red:

Code: Select all
Shader 'shaders\fxc\lightmappedgeneric_ps20b.vcs' - Couldn't load combo 171264 of shader (dyn=96)


No compile log errors; compiling without HDR; Episode Two.
User avatar
theCommie
Pheropod
Pheropod
 
Joined: Thu Oct 20, 2005 12:11 am

Re: Custom texture shows up white in-game

Postby ScarT on Sun May 03, 2009 12:09 pm

Tried removing $basealphaenvmapmask "1"?
User avatar
ScarT
Senior Member
Senior Member
 
Joined: Sat Apr 02, 2005 7:33 pm
Location: Denmarkian Land

Re: Custom texture shows up white in-game

Postby Nauz on Sun May 03, 2009 12:14 pm

Since you use a bumpmap, the specular mask has to be placed in the alpha channel of the bumpmap

remove basealpha thing, replace spec map and add $normalmapalphaenvmapmask "1" instead
User avatar
Nauz
Regular
Regular
 
Joined: Sat Mar 08, 2008 10:13 pm

Re: Custom texture shows up white in-game

Postby Kloetengott on Mon May 18, 2009 4:55 pm

Hi.
you can use the basetexture as container for the specmap of course!
You have to write $basealphaenvmapmask "0"
For any reason Valve starts to count from 0 on, when importing the specmap from your basetexture.
Kloetengott
Member
Member
 
Joined: Sun Feb 15, 2009 10:41 am

Re: Custom texture shows up white in-game

Postby Echo51 on Thu May 21, 2009 7:39 pm

i have same problem, except i only specified surfaceprop and basetexture..
Source is my way of life, if i didn't have it, i'd be tearing down walls and altering my house all the time.
"NEEDS MORE SPACE"
*creates 32kx32k brush for floor*
User avatar
Echo51
Pheropod
Pheropod
 
Joined: Tue Apr 28, 2009 6:00 pm

Re: Custom texture shows up white in-game

Postby stoopdapoop on Sun Nov 14, 2010 1:15 am

BUMMMPPPP, commie did you ever figure this out? I have this problem now.

Kloetengott may be on to the answer, but I'm not sure what he's saying :(
I'm Brown
Image
User avatar
stoopdapoop
Veteran
Veteran
 
Joined: Sun Aug 21, 2005 2:14 am
Location: Ann Arbor, MI

Re: Custom texture shows up white in-game

Postby Assigir on Sun Nov 14, 2010 11:55 am

@stoopdapoop try open up(in photoshop if you can) the diffuse and normal texture and check their channels, it happens to me some times that I save the textures/channels at wrong places which in turn gives withe textures in-game
-science: nothing can be destroyed only transformed into new forms.
-me: true death is a lie there is only transformation, unless sciences very core is wrong.


http://oscarkujanen.weebly.com/
User avatar
Assigir
Been Here A While
Been Here A While
 
Joined: Thu May 03, 2007 2:10 pm
Location: Sweden....near my computer

Return to Custom Asset Help

Who is online

Users browsing this forum: No registered users

cron