Drivable Vehicle Model [solved]

Got problems with your models? Struggling with textures? Get help with your custom assets.

Re: Drivable Vehicle Model

Postby crazycarl on Wed Dec 08, 2010 3:20 am

That looks alright. Do the wheels rotate correctly in model viewer? My second guess is that the game doesn't have the size of the wheels correct and you may need to tweak the vehicle script.
crazycarl
Been Here A While
Been Here A While
 
Joined: Tue Jan 12, 2010 9:12 pm

Re: Drivable Vehicle Model

Postby TheDanishMaster on Wed Dec 08, 2010 8:04 am

I had a look at it in the model viewer in some serious slowmo.. And it looked like when it started the animation the wheel got more and more speed and then it looks like it rotates 365-375 degress instead of 360. In 3ds max when i made the animation i had that snap thingy on and i rotated it exactly 360 degress forward.

If youre talking about the radius thing in the script you might just be right because I just changed it to 14 because i had no idea what the radius were. Is there any smart way to find out what it is?

Also.. Could it be because 3ds max smooths the animation too much? If so. do you know if theres a way to disable this smoothing crap?
Specs:
MSI P67A-GD55, Intel Core i7 Sandy Bridge 2600k @ 3,4GHz, Corsair 8GB DDR3 1333MHz, 1TB HDD, NVidia GTX580 1,5GB GDDR5, Blu-Ray drive
Image
User avatar
TheDanishMaster
Been Here A While
Been Here A While
 
Joined: Sun Jul 26, 2009 7:02 pm

Re: Drivable Vehicle Model

Postby TheDanishMaster on Wed Dec 08, 2010 8:20 pm

Ive got good in news... Well they might be bad :/
Because now it doesnt fuck up in Model Viewer and only ingame

WELL HAF U MAEK SHUR TO US DA RIGT ON IN DA GAM AS U DO IN MODEL VIVER?

Yes I have.. Only a mess ingame.. not in Model Viewer
Specs:
MSI P67A-GD55, Intel Core i7 Sandy Bridge 2600k @ 3,4GHz, Corsair 8GB DDR3 1333MHz, 1TB HDD, NVidia GTX580 1,5GB GDDR5, Blu-Ray drive
Image
User avatar
TheDanishMaster
Been Here A While
Been Here A While
 
Joined: Sun Jul 26, 2009 7:02 pm

Re: Drivable Vehicle Model

Postby crazycarl on Thu Dec 09, 2010 5:39 am

What I would do is set keyframes at 0, 3, and 6, and type in the correct rotation at each frame. You can use the curve editor in Max to control how it smooths animation, but I believe it uses straight linear curves by default, which is what you would want here anyway.

The radius and all those numbers are probably really important. There's a tape measure object in max that you can use to measure distances in max; measure from the wheel bone to the edge of the tire. The units Max uses is the same that Source uses.
crazycarl
Been Here A While
Been Here A While
 
Joined: Tue Jan 12, 2010 9:12 pm

Re: Drivable Vehicle Model

Postby TheDanishMaster on Thu Dec 09, 2010 8:23 pm

Ok I tried what u said. 3Ds Max was smoothing the animation so i disabled that.. The correct radius is 14.6 which is 0.4 smaller than what I first stated.

Did it work? Nope.. This is starting to piss me of :smt021 f
Specs:
MSI P67A-GD55, Intel Core i7 Sandy Bridge 2600k @ 3,4GHz, Corsair 8GB DDR3 1333MHz, 1TB HDD, NVidia GTX580 1,5GB GDDR5, Blu-Ray drive
Image
User avatar
TheDanishMaster
Been Here A While
Been Here A While
 
Joined: Sun Jul 26, 2009 7:02 pm

Re: Drivable Vehicle Model

Postby crazycarl on Fri Dec 10, 2010 3:49 am

Whelp, I'm out of ideas, then :(
crazycarl
Been Here A While
Been Here A While
 
Joined: Tue Jan 12, 2010 9:12 pm

Re: Drivable Vehicle Model

Postby TheDanishMaster on Fri Dec 10, 2010 4:16 pm

I FIXED IT!!!! :smt023
What I did was looking through the code crazycarl sent and then i spotted something...
Code: Select all
$poseparameter "vehicle_wheel_fl_spin" -180.00 180.00


Can u see whats wrong? No?

Well look at this

Code: Select all
$poseparameter "vehicle_wheel_fl_spin" -180.00 180.00 wrap


Can u see the difference?

I did have wrap at the end of them... and that seemed to fix it soo thx crazycarl even thoug :[]: h u didnt know
Specs:
MSI P67A-GD55, Intel Core i7 Sandy Bridge 2600k @ 3,4GHz, Corsair 8GB DDR3 1333MHz, 1TB HDD, NVidia GTX580 1,5GB GDDR5, Blu-Ray drive
Image
User avatar
TheDanishMaster
Been Here A While
Been Here A While
 
Joined: Sun Jul 26, 2009 7:02 pm
Previous

Return to Custom Asset Help

Who is online

Users browsing this forum: No registered users

cron