Page 1 of 1

Plantless Plant-Texture

PostPosted: Sun Oct 16, 2011 4:32 pm
by DA_iM
While working on my current mapping project today, i mentioned that anything is missing. I've created an outdoor area, coverd with trees and some fern-props. For the ground (displacement) i use the nature/blendmilground008_2_plants texture. Since the last update on Source SDK the plants seem to hide in the earth, argumenting that we have autumn, which isn't the best time to grow.... :cry:
So maybe anyone knows where they are hiding and how to get them "back to light" :?:

Thanks
DA!M

Re: Plantless Plant-Texture

PostPosted: Sun Oct 16, 2011 5:42 pm
by Post-Hoc
I'd suggest waiting until hammer is fully fixed. And if the plants are still underground after that post your .vmt file.

Re: Plantless Plant-Texture

PostPosted: Sat Oct 29, 2011 9:00 am
by DA_iM
so, waiting did not help yet, still get this error every time i compile my map. the detail sprites are missing in hammer editor 3d preview too!

"Material NATURE/BLENDMILGROUND008_2_PLANTS uses unknown detail object type militia_leaves_grass!"

militia_leaves_grass is an existing detail type in root/cstrike/details.vbsp

and the vmt file for nature/blemilground008_2_plants cotains an link ("%detailtype" "militia_leavesLgrass")!

VMT File:

"WorldVertexTransition"
{
"$basetexture" "nature/milground008"
"$basetexture2" "nature/milground002"
"%tooltexture" "nature/milground008_2_plants_tooltexture"
"%detailtype" "militia_leaves_grass"
"$surfaceprop" "grass"
//"$surfaceprop2" "rock"
}


how to fix this?

Re: Plantless Plant-Texture

PostPosted: Sat Oct 29, 2011 11:05 am
by Jordash
I'm assuming it a CSS map? for what ever reason the detail.vbsp isn't being loaded, do the default HL2 ones load? is the detail.vbsp still in the GCF? it has to be in the cstrike folder from what I recall.

Re: Plantless Plant-Texture

PostPosted: Sat Oct 29, 2011 11:37 am
by DA_iM
i found the detail.vbsp in the gcf file at css/cstrike
when i had a look to my "real" cstrike folder under steamapps/css/cstrike, i found and empty detail.vbsp there...oO an result of the updates this month i think.

i replaced the empty one with the extracted one from the gcf...and it works
great, thanks a lot =)