Having problems with 1 model, will pay 7$ for help

Got problems with your models? Struggling with textures? Get help with your custom assets.

Having problems with 1 model, will pay 7$ for help

Postby fpp on Wed Mar 06, 2013 3:47 am

Hi, i am having problems with a model i am trying to use on my hl2dm servers let me describe what i am trying to do.

I want to make this model http://unitedgamers.eu/cod/ULTIM.rar act like a bomb using this plugin https://forums.alliedmods.net/showthread.php?p=1789358 but the problem is it just gets stuck in the air, normally once you release a bomb it should "fly out of you" but this model just gets stuck in the air.

I have read on the plugin description quote "Some models tend to get stuck inside of each other and they all just freeze together. You just need to try some and find good ones that don't"

My friend that designed the model i am having issues with said it should look inside like the current model i am using "models/props_junk/PropaneCanister001a.mdl" and work, but it doesn't, it just freezes in mid air once its released.

I don't know anything about model designing or such and the few people i have asked have not been able to help me with it thats why i am turning to you guys.

If someone will be able to help me make this model work on my server with that plugin like the current one does i will give you a 7$ PaySafeCard in return, PaySafeCards are accepted in a lot of online stores, they are also accepted on Steam, i can also send it to you via Moneybookers(Skrill),this will take ~2-3 days though till i upload the funds.

Hope someone will be able to help me out with this, thanks in advance ! :smt023
fpp
Dumpling
Dumpling
 
Joined: Wed Mar 06, 2013 3:39 am

Re: Having problems with 1 model, will pay 7$ for help

Postby Black_Stormy on Wed Mar 06, 2013 9:21 pm

post .qc

Edit: I have no idea what you're trying to do but that video looks like it requires physics props. I assume your prop has been compiled as a static prop. Post .qc
User avatar
Black_Stormy
May Contain Skills
May Contain Skills
 
Joined: Sun Nov 28, 2010 6:03 am
Location: Cairns, QLD, AUS

Re: Having problems with 1 model, will pay 7$ for help

Postby fpp on Wed Mar 06, 2013 10:36 pm

I'll ask my mate that designed the model for it and post back, i don't know what that is cause i don't work with models but he probably will.
fpp
Dumpling
Dumpling
 
Joined: Wed Mar 06, 2013 3:39 am

Re: Having problems with 1 model, will pay 7$ for help

Postby fpp on Wed Mar 06, 2013 11:38 pm

fpp
Dumpling
Dumpling
 
Joined: Wed Mar 06, 2013 3:39 am

Re: Having problems with 1 model, will pay 7$ for help

Postby Black_Stormy on Thu Mar 07, 2013 10:19 am

$modelname Whipperz/UG_Bomb/UG_bomb.mdl
$cdmaterials "models/Whipperz/UG_Bomb"
$scale 12
$surfaceprop "metal"
$staticprop
$body mybody "UG_bomb.smd"

$sequence idle "UG_bomb" fps 30
$collisionmodel “UG_bomb.smd”
{
$mass 45
$concave
}
$keyvalues
{
“prop_data”
{
“base” "Metal.Small"
}
}


tell him to remove $staticprop and recompile it, although I'm not 100% it will work.
User avatar
Black_Stormy
May Contain Skills
May Contain Skills
 
Joined: Sun Nov 28, 2010 6:03 am
Location: Cairns, QLD, AUS

Re: Having problems with 1 model, will pay 7$ for help

Postby fpp on Thu Mar 07, 2013 10:24 am

Thank you, ill tell him when he comes online and test it out, if it does indeed work the cash is yours, ill post back as soon as i give it a try.
fpp
Dumpling
Dumpling
 
Joined: Wed Mar 06, 2013 3:39 am

Re: Having problems with 1 model, will pay 7$ for help

Postby Black_Stormy on Thu Mar 07, 2013 11:45 am

Not interested in your 7 bucks mate.
User avatar
Black_Stormy
May Contain Skills
May Contain Skills
 
Joined: Sun Nov 28, 2010 6:03 am
Location: Cairns, QLD, AUS

Re: Having problems with 1 model, will pay 7$ for help

Postby shadowmancer471 on Thu Mar 07, 2013 4:38 pm

Good guy stormy
Samaritan of interlopers
I want to get off Mr.Bones Wild Ride
shadowmancer471
Regular
Regular
 
Joined: Sat Aug 06, 2011 2:08 am

Re: Having problems with 1 model, will pay 7$ for help

Postby Major Banter on Thu Mar 07, 2013 5:04 pm

#ballin
ImageImageImage
Major Banter
Veteran
Veteran
 
Joined: Tue Apr 01, 2008 10:52 pm
Location: UK

Re: Having problems with 1 model, will pay 7$ for help

Postby LordDz on Thu Mar 07, 2013 6:17 pm

Can I have the money then? ;)
User avatar
LordDz
May Contain Skills
May Contain Skills
 
Joined: Mon Sep 01, 2008 12:28 pm
Location: Hammer Crash Logs

Re: Having problems with 1 model, will pay 7$ for help

Postby fpp on Fri Mar 08, 2013 1:10 am

I have tested it out, it acts the same as before,not working :smt010
fpp
Dumpling
Dumpling
 
Joined: Wed Mar 06, 2013 3:39 am

Re: Having problems with 1 model, will pay 7$ for help

Postby kraid on Fri Mar 08, 2013 6:03 pm

Try this one.
http://www.mediafire.com/?338c900oim0ruh3

I've done a new collision model and even improved the prop visually while still reducing the polycount i think.
Ofc. even better results could have been achived if the source files, especially the textures, would have been available uncompressed and in a higher resolution.
Image
Goldeneye Source v4.2.3
get it now and play for FREE!!!
http://www.goldeneyesource.net
kraid
Been Here A While
Been Here A While
 
Joined: Thu Jan 22, 2009 12:09 pm

Re: Having problems with 1 model, will pay 7$ for help

Postby Whipper on Sat Mar 09, 2013 2:12 am

Hello there

Guess it's about time i introduced myself, iv been visiting this site for some time now (sitting silently in the back) watching and reading some of the helpful and great work alot of the folk here do.. so first off i thank you.
I am the designer of that bomb mdl, i normaly map for hl2dm and have recently started to get more into creating models and props ect using blender.

Black_stormy,Kraid thanks for your help but sadly the model is still not working with fpp's server plugin, it still freezes and now looks like this:Image
Shame it didnt work but im going to give him something else to try, hopefully that works.
I have afew questions for you you both (probably help me when creating future mdls for the source engine) i noticed i may have used abit more polys than needed for the mdl & i noticed you have added a mask onto the diffuse texture of the bomb's fuse and fuse tip.. am i correct on thinking this is for the added $illumposition 0.000 0.000 0.000 in the QC?? also on the vmt you have Trilinear & Anisotropic checkd Why have both? or does that not matter? and why have you checkd the normal when it is not the normal map? and finaly black_stormy iv watchd afew of your vids on YouTube some nice work man, care to explain more about how to compile mdl's without GUIStudio.... i apologise for all the questions im new here^^

Cheers
Whipper
User avatar
Whipper
Member
Member
 
Joined: Sun Oct 28, 2012 1:09 pm

Re: Having problems with 1 model, will pay 7$ for help

Postby kraid on Sat Mar 09, 2013 4:21 am

As for your questions:
The normalmap checked on the diffuese is a mistake.
Also, please remove the 2 on UG_bomb_nrml2.vtf to make it appear instead of the checkerboard texture.
Simply a copy&past mistake i made there, sorry.
I've moved the spec mask to the normalmap and added a selfillum mask to the diffuse.
illumposition has nothing to do with that, its just the position at which the prop lightning will be sampled.
I left it in there for no particular reason, in fact setting it to 0.000 0.000 0.000 will leaf it at the prop origin, altering one of these values move it away from the origin.

If the prop still doesn't work, try to increase the weight or slightly decrease the size, preferably in your 3d app. not with scale in the .qc
Goldeneye Source v4.2.3
get it now and play for FREE!!!
http://www.goldeneyesource.net
kraid
Been Here A While
Been Here A While
 
Joined: Thu Jan 22, 2009 12:09 pm

Re: Having problems with 1 model, will pay 7$ for help

Postby Whipper on Sat Mar 09, 2013 5:33 pm

Thanks for the fast response & cheers for explaining more on the illumposition.
Iv resized the mdl and cut down on afew polys from the original smd. and gave the new compile bk to him, he will be testing it out later on 2night so fingers crossed it works^^

thanks once again.
User avatar
Whipper
Member
Member
 
Joined: Sun Oct 28, 2012 1:09 pm
Next

Return to Custom Asset Help

Who is online

Users browsing this forum: No registered users